A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 15:20 UTC
Investigating
We are experiencing delays with XRP deposits into WebAuth Wallet accounts. Rest assured, your transactions remain secure, and our technical team is actively working to resolve the issue. We appreciate your understanding and patience.
Posted Jun 11, 2025 - 10:29 UTC
This incident affected: XPR Network Bridge (Deposits).