Withdrawal Processing Delays

Incident Report for XPR Network

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 21:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 20:41 UTC

Identified

Our technical team has identified the issue. Please note that there may be delays in processing deposits to your account as well. We're actively working to resolve this as quickly as possible.
Posted Aug 21, 2025 - 19:07 UTC

Investigating

We are currently experiencing delays in processing withdrawals from the XPR Network (WebAuth Wallet). Our team is actively working to resolve the issue as quickly as possible. We appreciate your patience and understanding.
Posted Aug 21, 2025 - 18:30 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal).