Scheduled maintenance - Delay on crypto withdrawals and deposits
Incident Report for XPR Network
Resolved
The scheduled maintenance has been completed.

Thank you for your patience.
Posted Aug 20, 2023 - 11:11 UTC
Monitoring
Our crypto processor partner is doing scheduled maintenance which might delay crypto withdrawals and deposits on 20 August 2023 at 09:00 AM UTC for 2 hours.

Thank you for your understanding and patience.
Posted Aug 19, 2023 - 06:40 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal).