C-Chain Transaction History Delays

Incident Report for XPR Network

Resolved

This incident has been resolved.
Posted May 26, 2026 - 15:52 UTC

Investigating

We are currently investigating an issue affecting C-Chain transaction indexing.

Users may experience outdated or incomplete transaction history data in the explorer and wallet, including delays in reflecting cross-chain transfer activity. Balances and coin transfers should continue functioning normally.

Our team is actively working on a fix and we will provide updates as more information becomes available.
Posted May 26, 2026 - 12:02 UTC
This incident affected: XPR Network (Metal Blockchain).