Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2021 - 18:15 UTC
Scheduled
🧰. Our Client Services platform will be undergoing scheduled maintenance on Wednesday, December 1st. You may experience some delays in response times. We appreciate your cooperation while we make our Client Services platform even more awesome🤘
Posted Dec 01, 2021 - 18:11 UTC
This scheduled maintenance affected: XPR Network Client Services (Email, Live Chat, Knowledge Center).