Delays on Crypto Withdrawals and Deposits

Incident Report for XPR Network

Resolved

Our technical team has resolved the issue. We appreciate your understanding and patience.
Posted Sep 24, 2023 - 19:35 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2023 - 16:15 UTC

Update

We are working on resolving the issue that causes crypto deposits and delays.
Posted Sep 24, 2023 - 03:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2023 - 03:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2023 - 23:54 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal) and XPR Network Client Services (Email).