Our technical team has resolved the issue. We appreciate your understanding and patience.
Posted Oct 23, 2023 - 15:00 UTC
Investigating
We are currently investigating the issue leading to errors and delays with crypto deposits and withdrawals. Thank you for your patience and understanding.
Posted Oct 23, 2023 - 12:25 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal).