A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2024 - 07:56 UTC
Investigating
We have identified an issue with processing transactions. Our team is actively investigating the issue and working on a fix. Thank you for your understanding and patience.
Posted Apr 16, 2024 - 06:01 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal).