The Hedera mainnet upgrade has been postponed again and it will be upgrading mainnet to v0.41 on Wednesday, September 20th 2023 at 17:00 UTC.
Posted Sep 19, 2023 - 19:54 UTC
Identified
Due to the Hedera Mainnet Blockchain upgrade, crypto withdrawals and deposits for HBAR might be delayed on Tuesday, September 19th, 2023 at 17:00 UTC for 60 minutes.
Thank you for your understanding and patience.
Posted Sep 18, 2023 - 06:16 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal).