Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2021 - 18:44 UTC
Scheduled
🧰. Our Client Services platform will be undergoing scheduled maintenance on Monday, November 15th. You may experience some delays in response times. We appreciate your cooperation while we make our Client Services platform even more awesome🤘
Posted Nov 15, 2021 - 17:44 UTC
This scheduled maintenance affected: XPR Network Client Services (Email, Live Chat, Knowledge Center).