Intermittent delays with outgoing transactions
Incident Report for XPR Network
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 21:46 UTC
Investigating
Our transaction processing infrastructure is currently experiencing an issue causing a delay in finalizing the transaction status.
Posted Feb 20, 2024 - 20:02 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal) and XPR Network (Transactions).