Temporary Issues Affecting METAL Staking and C-Chain Transaction Indexing

Incident Report for XPR Network

Update

We are continuing to work on a fix for this issue.
Posted May 29, 2026 - 09:48 UTC

Update

Thank you for your patience.

We are currently addressing the issue with the WebAuth Wallet application. In the meantime, you may continue to use your Metal Wallet via the web browser to view your funds and initiate METAL staking.

Kindly log in at https://wallet.metalblockchain.org/. Should you require any assistance, please do not hesitate to contact us.
Posted May 29, 2026 - 09:45 UTC

Update

Thank you for your patience.

We are currently addressing the issue with the WebAuth Wallet application. In the meantime, you may continue to use your Metal Wallet via the web browser to view your funds and initiate METAL staking.

Kindly log in at https://wallet.metalblockchain.org/. Should you require any assistance, please do not hesitate to contact us.
Posted May 29, 2026 - 09:19 UTC

Identified

This issue has been resolved on the web platform. A fix for the WebAuth Wallet app is in progress and will be released soon.
Posted May 27, 2026 - 19:07 UTC

Investigating

We are currently experiencing a temporary issue affecting METAL staking, where users may be unable to select a validator from the validator list during the staking process.

In addition, we are investigating an issue impacting C-Chain transaction indexing. Users may notice outdated or incomplete transaction history data in the explorer and wallet, including delays in reflecting cross-chain transfer activity.

Balances and coin transfers continue to function normally.

Our team is actively working to resolve these issues, and we will provide further updates as more information becomes available.
Posted May 27, 2026 - 07:42 UTC
This incident affects: XPR Network (Metal Blockchain).