[Proton DEX] SSL Certification Issue
Incident Report for XPR Network
Resolved
The issue has been resolved.
Posted Jan 11, 2023 - 23:13 UTC
Identified
Please access the Proton DEX from this URL in the meantime

https://protondex.netlify.app
Posted Jan 11, 2023 - 22:54 UTC
This incident affected: XPR Network dApps (Metal X).