HBAR Deposit Delay into XPR Network

Incident Report for XPR Network

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 05:16 UTC

Investigating

We’re currently experiencing a delay with HBAR deposits into the XPR Network. Our team is actively working to resolve the issue, and all affected deposits will be completed automatically.

Thank you for your patience and understanding.
Posted Aug 27, 2025 - 20:46 UTC
This incident affected: XPR Network Bridge (Deposits).