Account Verification/Upgrade Issues

Incident Report for XPR Network

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 21:28 UTC

Update

We are continuing to investigate this issue.
Posted Dec 11, 2025 - 21:12 UTC

Investigating

Description: We are currently experiencing temporary issues affecting account verification and upgrade processes.

Impact: Users may face delays or errors when attempting to verify or upgrade their accounts.

Current Status: Our team is actively investigating and working to restore full verification functionality.

Next Update: We will provide an update as soon as more information becomes available.
Posted Dec 11, 2025 - 19:37 UTC
This incident affected: XPR Network dApps (Metal X Identity).