Transactions Processing Delays
Incident Report for XPR Network
Resolved
Our technical team has resolved the issue. We appreciate your understanding and patience.
Posted Jan 16, 2023 - 07:15 UTC
Update
We are continuing to investigate this issue.
Posted Jan 15, 2023 - 11:02 UTC
Investigating
We have identified a delay in processing the transactions. Our team is working to fix it. Thank you for your understanding and patience.
Posted Jan 15, 2023 - 11:02 UTC
This incident affected: XPR Network Bridge (Deposits, Withdrawal).